siliconehose.com
Thanks Thanks:  0
Results 1 to 3 of 3

Thread: 2010 Thundra 5.7 4x4 288kmi - P0300 on 5, 6, 7 & 8

  1. #1
    Rookie
    Join Date
    01-26-19
    Posts
    1
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default 2010 Thundra 5.7 4x4 288kmi - P0300 on 5, 6, 7 & 8

    I just got my truck out of body shop from hitting a deer which entire front end, from radiator, supports, bumper both fenders were replaced along with ac lines to inside cabin. I have taken back to body shop already to replace missing lock/unlock tone module, install missing bolts and tighten others and reinsert a driving light in bumper not in correctly and the newly replaced passenger headlight motor is stripped out and new one on the way. I had to adjust my headlights due to the tech said he did but were aiming to ground and control had max up. Tech showing me how to adjust I noticed he was not aware he was telling me incorrectly and I just let him talk and told him I would do later. This has made me think that the reason I am now throwin po300, p0305,p0306,p0307 & p0308 that possibly they missed something damaged or have something not plugged in completely or broke a connector or left a ground loose. It may crank again and run fine for miles and no codes then next time, the check engine, skid light and 4LO ,lights start flashing and I lose power. and sometimes, the p0305 & p0308 codes are absent but always the 300, 306 & 307 ??? Thank you for any suggestions.

  2. #2
    Pro Class
    blackdemon's Avatar
    Join Date
    11-20-08
    Location
    NorCal
    Posts
    792
    Gameroom Cash
    $21544
    Post Thanks / Like
    Rep Power
    21

    Default Re: 2010 Thundra 5.7 4x4 288kmi - P0300 on 5, 6, 7 & 8

    By any chance is it ingesting any water or coolant??? also have you attempted to swap the affected coils with other non affected coils?? additionally how is it idling??

    apples to oranges... my Celica had this issue ingesting water during a storm and got a p0300 and a p0304 which is the closest cylinder to the intake... after I was able to clean all the water out of the throttle body it started idling low, which turned out to be the IAC valve that needed cleaning... mine is running fine now, but again it may be a similar issues since its apples to oranges, but you did indicate the wreck prior to the issue.
    __________________
    (. Y .) my anti-drug

    Mods
    -Front License plate removed
    -FJ Cruiser Running Boards
    -White Turn signals
    -Truck Covers USA Roll Cover
    -Laufenn XFit AT 275/65-R18
    -TRD anti-squat bar
    - Optima Yellow top

    Up coming Mods
    -VLED interior lights

  3. #3
    TG Super Moderator
    tonyspin's Avatar
    Join Date
    01-31-09
    Location
    Long Island
    Posts
    4,276
    Gameroom Cash
    $83818
    Post Thanks / Like
    Rep Power
    82

    Default Re: 2010 Thundra 5.7 4x4 288kmi - P0300 on 5, 6, 7 & 8

    Wow. What kind of a shop delivers a vehicle to a customer in this condition? If you had none of these issues before the accident, they should be corrected by them. You may have recourse with your insurance company if these issues were not in the original estimate.

Similar Threads

  1. P0335,P0340,P0300
    By Catamount in forum Ask The Professor!
    Replies: 2
    Last Post: 11-20-2014, 09:38 AM
  2. 2010 CrewMax LTD
    By bombtek2308 in forum 2007/2013 Tundra Build Logs
    Replies: 13
    Last Post: 04-03-2013, 11:29 AM
  3. So Cal: ALL TOYOTAFEST XV - May 8, 2010
    By TacoMEDIC in forum West
    Replies: 13
    Last Post: 05-12-2010, 08:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •