siliconehose.com
Thanks Thanks:  1
Results 1 to 9 of 9

Thread: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

  1. #1
    Rookie
    Join Date
    07-29-17
    Posts
    6
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    Hi, new member, trying to find some advise and assistance.
    2005 SR5 Tundra 4.7 4X4 280,000 miles
    Aside from normal wear, she has always run like a champ. Never gave me ANY engine trouble (an occasional system too rich code) but never any running issues.
    I don't drive her throughout the week as i have a company vehicle, but here's the short story...
    She drove fine on a sunday, parked for 5 days, and on friday all she would do is start and then die after about 5 seconds. It does this every single time and starts without fail, but as I mentioned, immediately dies. So far i have:
    replaced the MAF
    cleaned the throttle body
    checked fuel pressure (had to fabricate a pressure port with a banjo bolt) resulting pressure is 32psi on start, 28psi after 6 minutes.
    I can't get a pressure reading at idle, since it won't....
    Tried following the chilton manual on determining the source (it says either pump/strainer or fuel pressure regulator, however the test to determine which won't work as it needs to be idling...)
    So, I ordered a new pump motor and mesh filter, as well as a new pressure regulator, in the hopes that one of the two will be the fix.
    Now I have a new issue-- in anticipation I dropped the tank to get to the pump so i can be ready when the new one arrives. unfortunately, as I was trying to disconnect the plug, it slipped off the jack, and subsequently pulled the wires out of the plug. now i have two BIG dilemmas that i hoped you all could help with.
    ONE- any suggestions that I haven't looked at on the stalling?
    TWO- can anyone tell me the color codes for the plug? the Wiring diagrams don't show it anywhere...
    any assistance is appreciated! I am pretty good at working on engines, but this one has me stumped...
    no engine codes...

    Thanks in advance!
    Patrick

  2. #2
    TG Super Moderator
    tonyspin's Avatar
    Join Date
    01-31-09
    Location
    Long Island
    Posts
    4,124
    Gameroom Cash
    $83818
    Post Thanks / Like
    Rep Power
    76

    Default Re: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    Any codes?

    Edit: Ah, now I see no codes. Have you checked all fuses?
    Last edited by tonyspin; 07-30-2017 at 04:11 AM.
    __________________

  3. #3
    Rookie
    Join Date
    07-29-17
    Posts
    6
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default Re: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    no codes.

  4. #4
    Rookie
    Join Date
    07-29-17
    Posts
    6
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default Re: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    yes, all the fuses are ok. in fact I had spares, so i replaced them just to be sure....

  5. #5
    TG Super Moderator
    tonyspin's Avatar
    Join Date
    01-31-09
    Location
    Long Island
    Posts
    4,124
    Gameroom Cash
    $83818
    Post Thanks / Like
    Rep Power
    76

    Default Re: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    Sometimes it is worth paying the dealer fee to diagnose the problem.

  6. #6
    Rookie
    Join Date
    07-29-17
    Posts
    6
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default Re: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    that's going to be the next step once i get the new pump and pressure regulator... now the only issue is the wiring color code for the pump/sending unit plug-- they pulled out and I don't know which go where....
    thanks,

  7. #7
    Pro Class
    chphilo's Avatar
    Join Date
    10-19-10
    Location
    PA
    Posts
    594
    Gameroom Cash
    $17049
    Post Thanks / Like
    Rep Power
    15

    Default Re: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    Worth checking. Make sure that all the air hoses (from intake to the engine) are tight. Happened to me. Engine will start and die immediately. It turned out that the air hose from the intake to the engine came loose (little gap). Tightened it, then it worked like a charm.
    __________________
    2010 Tundra, Crewmax, 4x4, 5.7, TRD Off-Road, SR5, Silver Sky Metalic, Brushed Stainless Steel Stepboards, Tinted Window, Pioneer AVIC Z140BH, Pioneer ND-BC5 Rearview Camera, Metra Axxess Steering Wheel Control Interface, Line X Extra with Color Match, ValuGard Undercoat, ValuGard Rust Inhibitor, AVS Window Visor, Clazzio (black/red), TRD Cat-Back Exhaust System, TRD Intake, Toyota Hood Protector, Husky WeatherBeater Floor Liners, AMI TRD Third Brake Light Cover, Westin Ultimate Bull Bar, Westin Chrome Off-Road Lights, TRD License Plate Frame, B&W Tow and Stow, Moto Metal 961, Bushwacker fender flares, G-Tek Fab Door Sill Protectors, BAKFlip F1, Momo Combat Evo Red Shifter, Diode Dynamics accent plate (Console, cupholder, door pull inserts), Wheelskin, OME 614 kit, LR UCA, Undercover SwingCases, Toyota Tow Mirrors, Nitto Trail Grappler (295/70/18), Amp bed step

  8. Thanks Dez "Thanks for this post"
  9. #8
    Rookie
    Join Date
    07-29-17
    Posts
    6
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default Re: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    Turned out that some squirrel ate my harness... little bastard. he also ate through one of the airbag wires, but toyota won't fix that (liability) so to fix that would be $3k....but they did fix all the others for $300...

  10. #9
    TG Super Moderator
    tonyspin's Avatar
    Join Date
    01-31-09
    Location
    Long Island
    Posts
    4,124
    Gameroom Cash
    $83818
    Post Thanks / Like
    Rep Power
    76

    Default Re: 05 SR5 4.7 won't idle.. dies as soon as I start it. help please

    Wow....dam squirrels!! Where was the harness that was chewed?

Similar Threads

  1. Blackwidow dies again
    By Black Widow in forum IF5.7 General Discussion & Help
    Replies: 122
    Last Post: 06-02-2013, 06:37 AM
  2. Cammed LS6 idle clip
    By Luke03 in forum IF57 Race Group
    Replies: 10
    Last Post: 05-29-2011, 09:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •