siliconehose.com
Thanks Thanks:  1
Results 1 to 9 of 9

Thread: P0335 and no start

  1. #1
    Rookie
    Join Date
    03-28-19
    Posts
    5
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default P0335 and no start

    I have a 5.7l Tundra with 209k miles

    Today my truck is stalled out. I ran an errand and it died on me. I tried to turn over and I got a click and no start. After a few tries it started with a CEL P0335 crankshaft sensor position circuit A malfunction. I got home and it died, I can no longer turn it on. I purchased a new sensor and swapped it out and I still get no start. I'm at a loss at this point. I have an optima yellow top battery, but Ive yet to test it out. When I turn over I get a click but nothing else. Stock alarm and everything else. Any help is greatly appreciated.

  2. #2
    Rookie
    Join Date
    03-28-19
    Posts
    5
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default Re: P0335 and no start

    So.... got it to turn on. Foolishly i pulled it out just outside my neighborhood and it stalled out on me....... i did notice a low rpm dip below 400rpm..... I accelerated and it somewhat normalized.... at a stop sign it completely stalled out and I cant get it to come back to drive home a half a mile... lol... Im not sure what else to check.... looked at all grounding points and all seem to be good...

  3. #3
    TG Super Moderator
    tonyspin's Avatar
    Join Date
    01-31-09
    Location
    Long Island
    Posts
    4,246
    Gameroom Cash
    $83818
    Post Thanks / Like
    Rep Power
    81

    Default Re: P0335 and no start

    Found this:

    Use live scan tool to check that there is a RPM reading when the engine is running.
    Conduct a visual inspection of the crank sensor and connectors and search for signs of fraying/damage to the wiring.
    If no visible damage is found, you can check the CKP 5 Volt square wave pattern. You will have to reference your vehicle’s repair manual to determine which resistance reading is sufficient. This reading will come from the vehicle’s PCM.
    If you are not familiar with vehicles, it is best to leave this step to a professional.
    If the reading is within the specifications of the vehicle, no need to replace the crankshaft position sensor
    However if the reading is NOT within the specifications of the vehicles, the crankshaft position sensor should be replaced.
    Replace any frays/damaged wiring and if the reading is within the specifications now, there may be a short in the wiring.
    *If these steps do not locate your issue, it may be within your PCM and you will need to take it to a mechanic for further diagnosis.

    Good luck. Let us know what you find

  4. Thanks Blackdemon_tt "Thanks for this post"
  5. #4
    Rookie
    Join Date
    03-28-19
    Posts
    5
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default Re: P0335 and no start

    Actually, It sounds like the starter. I'm in the enjoyable process of removing it right now. I saw it on youtube. Not the best place for advice but it was exactly the same sounds mine was making, and around the same mileage.

  6. #5
    TG Super Moderator
    tonyspin's Avatar
    Join Date
    01-31-09
    Location
    Long Island
    Posts
    4,246
    Gameroom Cash
    $83818
    Post Thanks / Like
    Rep Power
    81

    Default Re: P0335 and no start

    Good luck. I hope it solves the problem.

  7. #6
    Rookie
    Join Date
    03-28-19
    Posts
    5
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default Re: P0335 and no start

    Its official, the starter was dead... i may be wrong but the starters seems to die around the 207-210,000 mile mark. Some vids I saw on youtube seem to be around the same mileage... including the Sequoia.. not a lot of space in some areas, but seems to be about a 12 hour job with long breaks and thoughts about the meaning of life while trying to figure out how to get to some bolts.. Either way... seems like a p0335 is a good indication that the starter might be dead... I got 1 warning and I took it home where it died.

  8. #7
    TG Super Moderator
    tonyspin's Avatar
    Join Date
    01-31-09
    Location
    Long Island
    Posts
    4,246
    Gameroom Cash
    $83818
    Post Thanks / Like
    Rep Power
    81

    Default Re: P0335 and no start

    Thanks for adding to the data base here. How much was the starter?

  9. #8
    Rookie
    Join Date
    03-28-19
    Posts
    5
    Gameroom Cash
    $5000
    Post Thanks / Like
    Rep Power
    0

    Default Re: P0335 and no start

    Rockauto O.E. TYC starter was $117. No core exchange, so theoretically I can rebuild mine and have a spare. Btw didnt remove the exhaust nor header. I would recommend a youtube vid, with a few exceptions referencing the cooling lines.. It is a Cali King size B, but can be done..

  10. #9
    Pro Class
    blackdemon's Avatar
    Join Date
    11-20-08
    Location
    NorCal
    Posts
    773
    Gameroom Cash
    $21544
    Post Thanks / Like
    Rep Power
    21

    Default Re: P0335 and no start

    Sorry for the delay, but this was my problem, I couldn't remember which email I had used so I created a new profile to seek help while I figured this account....

    I've been pre-occupied with work and other stuff... but my process of elimination did involve replacing the crankshaft position sensor first to no avail... I jumped it via a 4 cylinder car with no result... so I swapped the batteries since I have Optimas, I took the battery for a joy ride and returned a d swapped out the batteries. At this point it actually turned on on the 2nd try and stayed on, so I ventured around the neighborhood where I broke down literally 3 blocks from my house so I built my courage pulled my Celica out and got the battery tested and it was actually low and required a recharge, luckily I did have 6 months left on the warranty, so I exchanged it and still no start. I also swapped out the fuse and relay to the same result. I even tried jumping it via a 20 gauge wire, not easy by any means since it doesn't come with a diagram anymore, I could hear a click but got nothing. At this point I figured it was the starter, but honestly I was in denial, especially since I was 3 blocks away from home..... I broke down at about 3 and didn't call a tow till 11pm...

    I ended up smashing my phone so I have some pictures which I will post as soon as I get my data out of old cell to my new phone.
    Last edited by blackdemon; Yesterday at 09:14 PM.
    __________________
    (. Y .) my anti-drug

    Mods
    -Front License plate removed
    -FJ Cruiser Running Boards
    -White Turn signals
    -Truck Covers USA Roll Cover
    -Laufenn XFit AT 275/65-R18
    -TRD anti-squat bar
    - Optima Yellow top

    Up coming Mods
    -VLED interior lights

Similar Threads

  1. P0335,P0340,P0300
    By Catamount in forum Ask The Professor!
    Replies: 2
    Last Post: 11-20-2014, 09:38 AM
  2. Remote Start
    By NoBloodNoFoul08 in forum NEW MEMBER INTRODUCTIONS, Site Rules & Info
    Replies: 17
    Last Post: 12-11-2013, 06:57 PM
  3. please help oem remote start
    By chirojh in forum 2007/2013 Tundra Issue Discussion
    Replies: 2
    Last Post: 02-01-2013, 02:32 PM
  4. Loud Start Up
    By Prizmatik in forum 2000/2006 Tundra Maintenance/Repair/Specs/Warranty Discussion
    Replies: 12
    Last Post: 12-03-2012, 04:41 PM
  5. 07' 5.7L Tundra won't start
    By richbrismith in forum 2007/2013 Tundra Issue Discussion
    Replies: 9
    Last Post: 12-30-2011, 06:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •